Microsoft Services

Incident Report for Fearnley

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 22:05 UTC

Monitoring

Microsoft expect full recovery by 23:20 UTC on 29 October 2025 and we have observered recovery of Microsoft services at Fearnley Group already.
Posted Oct 29, 2025 - 20:25 UTC

Investigating

We're aware of an issue affecting Microsoft Services, Microsoft Applications may be slow to load.
Posted Oct 29, 2025 - 16:06 UTC
This incident affected: NS Reporting App.